mbruck

Members
  • Content Count

    30
  • Joined

  • Last visited

Everything posted by mbruck

  1. Croatian characters country code page not supported. Country code 1250 (Central Europian) As I know Croatian country code is 1250, and it is not supported, at least in version I just download from site. 5.79A build 1574 (trial) I send two prints screen, first what is shown in DaqFactory, and second what really should be on the screen. As you see on first screen even if I chose CE subfont (Central European), valid characters still don't show correctly. How can I get our character's show correctly? Reghards
  2. My initial post about this issue was 6 years ago. Then I (we) got promise about version 6 and unicode support. I see there is no version 6 yet (and probably never be, according to time spent to develop from 5.9 to 6.0), but is there a unicode support at least ? I'm trying to convince one buyer for developer version, but it is hard without unicode support. Any (reasonable) comment? If possible, please, without "we are working on it" since obviously you are not. Mladen Bruck Hercegovina
  3. Please, could some one explain more about ModBus TCP, Slave and Master configuration. What confusing me is , id terminology: Modbus TCP slave is Ethernet master and vice versa . "Slave is master" More, when configuring devices there several possible combination: MODBUS TCP, Modbus TCP slave and New Ethernet (TCP) client, New Ethernet Server .... I have succesfully connect DaqFactory to one Modbus TPC application where read input status (F2), but I can't READ FROM DAQFactory. Even I try several combination above, I never success to establish communication. Please, could you explain how to establish TCP communication QuickMOD<->MyApplication in somple steps! Thank you!
  4. mbruck

    Version 6

    Version 6..... ? Promised more then......two years ? As I remember.
  5. mbruck

    Force Coil Modbus TCP function

    Hello! I have problem with Force coil modbus tcp function (5). When I put ordinary button and connect it to Force Coil tcp function channel, it always send xFF in data part. This is same for all type button & Switches, EXCEPT for spin button which send x00 and xFF when push upper and lower part. On attached print screen, first push send xFF and LED is "on" on button, but second push actualy switch off button and LED, but channel show same data is sent to device (and device respond to it)..... Problem. My question is, how to setup, embedded buttons&switches to sent x00 or xFF, and how to do same with simbol factory "buttons" . Regards!
  6. I'm considering to buy DAQFactory (PRO?), but your license policy confuse me... sorry. Can I buy: For ME: DAQ Factory PRO + one runtime,(+ hardware key to move it on my laptop), to develop and test application on my computer For Customer: ONE runtime license to run application what I developed above? What should I install on customer PC?
  7. mbruck

    Force Coil Modbus TCP function

    Here it is... test.ctl
  8. No, no... It is only for screen messages! Look previous posts. I will not put any Croatian characters into communication streaming....
  9. No hard feeling.... Many manufacturers wouldn't even publish my comment.
  10. This is promise more than YEAR AGO. I still waiting for version 6.0 and Unicode support. Unfortunate, many software developers like to PROMISE, more than WORK. (It seam you are one of them)
  11. When you expecting release 6.0 version and what is upgrade policy if I buy current version before?
  12. I'm considering to run DAQFactory on WINCE based terminal. Is this possible? Concretely like this one: http://cubloc.com/product/05_03.php or 3200 or 3500 from same site....
  13. I know I make newbe question, but I can't find answer in documentation. How to deploy program and license to user computer if I buy DaqFactory Pro version? I know user have to buy license, but how? And what about DaqFactory program? So, basicaly my question is: As developer I have DaqFactory Pro version. What my customer have to buy and install to run application I developed with my version? Thank you!
  14. YES. False alarm. Very sorry. Problem was with my input routine in BascomAVR. "Input" return whatever is typed in serial input if echo is on. I swicth echo off, and voila, problem solved.
  15. Hello! I have created new serial device and pointed to COM1 and name it Com_Port. I have succesfully created new protocol according to serial guide and no problem receiving data from Com1. But when I try to send data with write() function with following sintax: device.Com_Port.Write("TEST") system return error C1000 Channel or function not found.... BUT data are sended to com1 and appear on my virtual machine (Proteus ISIS) and Comm monitor too (TX: TEST), as you can on my print screen. How to send data without this error? Do I have do it throw channel? Thank you.
  16. No problem.. I send you notepad file, believe most easyer to analyze. Also print screen how characters look like lower and upper case. Regards! CRO_Characters.txt
  17. Yes no problem. I make new and very small application. I create new serial device (as I described in previous post) and use NULL protocol as you suggested. And I didn't make any sequence for receive or sending. And now one very nasty bug. When ever I send chr(13), program put in receive buffer chr(13) and chr(10). Example: With this sequences: device.Com_port.Write(" Button 1") device.Com_port.Write(chr(13)) Comm monitor show this: With this sequences: device.Com_port.Write("Button 2 without chr(13)") I really plan to buy this program, but this is very frustrating at the very beginning.... Comm monitor show this: And when I send ONLY characte 13 with device.Com_port.Write(chr(13)) Comm monitor show this: This clearly show that any chr(13) in transmit bytes sequence trigger "receiving ghosts" chr(13) and chr(10). I send you .ctl application. DaqFactory version is ProRelease 5.79A Build 1575 - Trial version (with patch for Croatian characters from another post) OS: Windows XP with SP2 on WMvare Workstation I really plan to buy this products, but this behavior is very frustrating at the very beginning. This eating my trial period which I was plan to make something usefully for learning DaqFactory. (I want my time back ) com_port_test.ctl
  18. I have done as instructed, program start regularly, but there is no any change. Still there is no Croatian characters.
  19. Ok. I folowed your manual. I do this: 1. Quck - Device configuration - New Serial (RS232/468).... 2. Device name: Com_Port 3. New Serial : Connection name COM1 (Serial port # 1 ... bla bla) 4. New protokol, name GET_PUT_COM_PORT (same file name+ddp in DAQFactory folder) 5. On receive event code (as in manual): if (strIn == chr(13)) // we've received the EOL character private string DataIn = ReadUntil(13) Channel.AddValue(strDevice,0,"Input",0,StrToDouble(DataIn)) endif Receive from com1 work. I create channel as described in manual. Receive work! No problem! "...did you put any code in the OnSend function?" "On Send" is triggered after actual sending to com port. It's irrelevant to my problem. You might try selecting the NULL protocol No. Why should I? In fact I do as you described in manual, why should I change to NULL now? This is quite enough for me now. Maybe you can add in manual how to send data, after you describe how to receive? Now I only need how to send data with created device (Com_Port), from sequence or from screen component (eg. button action "Quick sequence"). How? And without error which was my first question.
  20. Device name is Com_port. Com port name is COM1. As you see I referenced device name com_port. (device.Com_port.write...) I try put this sentence on button action "Quick sequence", but same message appear. device.Com_Port.Write("000"+chr(13))
  21. mbruck

    HMI Screen design

    Thank you. I'll try my best, then ask if stuck.
  22. Searching the web and previewing the screens on your site I may see very nice GUI HMI screens, and make me wander: HOW they made this? So I wander is possible to make series of small tutorial's (from your guru) for us totally beginners, about tips and tricks making user screens. E.g. for me is very intersting how thay make this page: http://www.azeotech.com/imagezoom.php?src=...sscreenshot.jpg How is make tank ingredients (brown liquid) to rise up and down? This is just one question, I can make dozen of them. I believe you understand what is my point. Regards!