Sign in to follow this  
mbruck

Croatian characters country code page not supported.

Recommended Posts

Croatian characters country code page not supported. Country code 1250 (Central Europian)

As I know Croatian country code is 1250, and it is not supported, at least in version I just download from site. 5.79A build 1574 (trial)

I send two prints screen, first what is shown in DaqFactory, and second what really should be on the screen.

As you see on first screen even if I chose CE subfont (Central European), valid characters still don't show correctly.

How can I get our character's show correctly?

Reghards

post-2477-1221727201_thumb.jpg

post-2477-1221727217_thumb.jpg

Share this post


Link to post
Share on other sites

(Please read post below as this didn't work. Attachment was removed)

Did you try Arial in DAQFactory? I'll assume so.

Try the following:

1) download the attached DLL (inside the zip file)

2) Copy it into your DAQFactory directory

3) Start up RegEdit to edit your registry (start - Run - regedit)

4) browse to HKEY_LOCAL_MACHINE/Software/DAQFactory/Control

5) select Edit - New - String Value to add a new value. Call it "LanguagePack". Note the caps and no spaces.

6) set this value to lang_croat.dll

7) quit registry editor and start DAQFactory and see how it works.

Share this post


Link to post
Share on other sites

No. Program just do ping-ping very fast and won't even open anymore. When I remove LanguagePack registry item, it work normally, but same problem exist.

Share this post


Link to post
Share on other sites

I thought that might happen. Try this instead:

1) I've put a patch up at www.azeotech.com/daqfactory.exe. This will be included in the next release, but we're not going to release for a simple little change, but I don't want you to wait. Copy the file over the existing in your DAQFactory directory.

2) browse to HKEY_LOCAL_MACHINE/Software/DAQFactory/Control and delete the LanguagePack setting you created

3) Add a new DWORD value called CodePage and set it to your code page number (1250)

4) start up DAQFactory

No guarantees that this will work, but this is the only other mod we can make on short notice. Tell me how it does.

Share this post


Link to post
Share on other sites

I have done as instructed, program start regularly, but there is no any change. Still there is no Croatian characters.

Share this post


Link to post
Share on other sites

OK, can you please post a simple document with a text component that should show croatian characters, and perhaps a screenshot of what the text should look like?

Share this post


Link to post
Share on other sites

I'm not completely sure that that will do what I want. Can you take those same characters and put them in a DAQFactory Text component, then post the .ctl file? Windows can sometimes do weird things when you cut and paste and I'm afraid it will alter the characters since I'm not on the same code page by default.

Share this post


Link to post
Share on other sites

Did you type the characters directly into DAQFactory, or did you cut and paste them from Notepad? Make sure you type them directly in.

Share this post


Link to post
Share on other sites

I'm not sure why it won't take. The code page is being set correctly, but the characters still don't display correctly. I'm afraid I don't have a solution for you, other than using bitmaps for your text displays that you generate in Paint or another program instead of text. DAQFactory release 6 will be fully unicode and will not have this issue.

Share this post


Link to post
Share on other sites
DAQFactory release 6 will be fully unicode and will not have this issue.

This is promise more than YEAR AGO.

I still waiting for version 6.0 and Unicode support.

Unfortunate, many software developers like to PROMISE, more than WORK. (It seam you are one of them)

Share this post


Link to post
Share on other sites

We are working. Just on different things, namely the DAQConnect service. Unfortunately, most businesses have to work on the things that will make them money, and Unicode support is below real time web access (and other things) on the "will make money" scale, especially since you should be able to use unicode in DAQConnect (though truthfully we haven't tried it). You may think it greedy, but all software developers need to eat, and unless we make money, we don't eat.

Share this post


Link to post
Share on other sites

No worries. I want unicode support just as bad as you. Unfortunately, its actually kind of complicated for DAQ software tools that support serial and ethernet because of course, serial and ethernet is typically straight ASCII characters.

Share this post


Link to post
Share on other sites
Unfortunately, its actually kind of complicated for DAQ software tools that support serial and ethernet because of course, serial and ethernet is typically straight ASCII characters.

No, no... It is only for screen messages! Look previous posts.

I will not put any Croatian characters into communication streaming....

Share this post


Link to post
Share on other sites

Oh, I know, but once you compile the app using Unicode, then EVERYTHING ends up being unicode if you use the standard libraries. Thus the programming challenges. The serial data is of course just ASCII, but if it gets read into a string internal (which is unicode) it will get misinterpretted.

Share this post


Link to post
Share on other sites

Some additional info, maybe will give some clue:

I developped an application with Hebrew Character set on my laptop. No problems.

Codepage is 1255

When I changed laptop - I got all garbled out.

System is XP sp3, and I use DaqFactory 5.81.

I now try to move app to another computer to see if that solve.

I dont know yet where in the PC definition something do not allow the character set.

Share this post


Link to post
Share on other sites

My initial post about this issue was 6 years ago. Then I (we) got promise about version 6 and unicode support.  

I see there is no version 6 yet (and probably never be, according to time spent to develop from 5.9 to 6.0), but is there a unicode support at least ?  I'm trying to convince one buyer for developer version, but it is hard without unicode support.

Any (reasonable) comment? If possible, please, without "we are working on it" since obviously you are not.

 

Mladen Bruck

Hercegovina

Share this post


Link to post
Share on other sites

Yup, and my apologizes for the lack of progress on this.  Most everything I can say has already been said.  We don't get many support issues regarding alternate character sets, possibly because customers use bitmap images when needed, and so this feature is down on the list, even though I personally would love to see it happen.  Also, unicode is not necessarily the answer.  In the time since your original post, the world has standardized more on UTF-8.  It is much more likely we will support this than unicode as this does not require a recompile, it simply requires us to modify the screen controls to properly interpret the characters.  Modifying the screen controls will also solve some other issues (scale and pan), but its quite involved if we are trying to maintain backwards compatibility.  Its been an internal conflict for some time, trying to find the best way to move forward without losing backward compatibility, and as such is taking longer than I would hope.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this