Failure in reading input data


Recommended Posts


On running a ctl document on the DAQFactory Express, I had some trouble in reading the input data.

Connecting a LabJack U3-HV to a PC through the USB, the program failed to read the input data.

I checked the status of the LabJack U3-HV, which is shown on "LabJack1.jpg".

Device No. is set "0" on the ctl document.

Then I reinstalled the LabJack, the status of which in shown on "LabJack2.jpg", and this time

the program worked fine, reading properly the input data.

Since the status of "LabJack1.jpg" does not seem to have any problem, I wonder what is the problem.

How should I understand the difference?

Link to comment
Share on other sites


Thank you for your comment above which just coincides my experience below.

After several trials, I found out the reason that had caused the problem I mentioned.

On the state of "LabJack1.jpg", it was LJCP that holded the LabJack open and interfered

DAQFactory Express(ctl document) from reading the input signals.

After closing LJCP then opening DAQFactory Express, DAQ worked fine.

With DAQ kept open, re-opend LJCP showed "LabJack2.jpg"!

So my lesson is "LJCP must be closed when opening DAQ"!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.