Sign in to follow this  
cragjumper

Streaming >1000Hz , Timestamp Issues With Excel Time

Recommended Posts

Hi all,

I've been working on streaming some data, namely some digital inputs on FIO4-7. I'm successfully streaming channel 193 and getting good data. However, when I try to use scanrates>1000, I start running into timestamp issues, where blocks of data all have the same timestamp. My guess is that it's an issue using excel time - perhaps excel time doesn't have capacity for resolution > .0001 seconds?

When I turn off excel time, it seems to run fine (obviously I have to calculate time differently since it's now seconds from 1970).

In case I wanted to use excel time, do you know a way around the limitation in resolution?

Thanks!

Share this post


Link to post
Share on other sites

There is a setting in logging sets which determines the precision of time stamps. Since excel time zero point is 1900 instead of 1970 it needs more precision to get to smaller time intervals. The max precision of a double float is 15 to 16, so you still might max out. If you can't get the desired precision, you might consider switching to DF time (excel time not checked) and then simply making the start of the experiment as the zero time using some simple math in excel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this