Sign in to follow this  
raining010

Resident Alarm Data

Recommended Posts

Hi, Admin

 

I met a strange thing about DF alarms today. While I started program, there were some active alarms, but actually there was no alarm (no alarm data from outside via communication). I checked the data, these alarm happened in last year.

 

I tried to restart the program many times, but these alarms were always active. Why? And how to clean these? I use 5.87a

 

Thanks

Share this post


Link to post
Share on other sites

The alarms must have been fired when you saved the document.  Take some data so they clear out, then save the document again. 

Share this post


Link to post
Share on other sites

Hi,

 

I can't do this now. Because the computer will serial port card only has runtime license, doesn't have save button. The program is copied into this desktop computer.

My laptop has pro license, but don't have serial port card.

Is there any code(sequence) to clear this?

 

About this alarm, here are more details,

The alarm line keeps red(no flash), even I reset it(in the reset place of alarm value).

 

Besides, I found the alarm description can't be translated to other language. I use @ here, but doesn't work.

Why I can't upload the photo? It will be more clear

 

thansk

Share this post


Link to post
Share on other sites

Yes, a screenshot would be helpful.  You should be able to upload photos, but may be limited to compressed types (gif, jpg, png).  I believe we restrict bmp files because they are so big.

Share this post


Link to post
Share on other sites

I give up, every time I update the picture, it says 100%, but later changes to 'upload failed'. My picture is only 100 kb, jpg.

 

By the way, in the alarm window, does @ work for translation? I tried, but failed

 

And is there any command/way to clear these kept data?

 

Thanks

Share this post


Link to post
Share on other sites

OK, your Reset expression on your alarms look something like this:

 

Reset_alarms&&(DI_FANS_FAULT[0]==0)

 

So, in addition to the alarm flag resetting to 0, Reset_alarms has to be 1 as well.  You have a button that sets Reset_Alarms for 3 seconds then sets it back to 0.  The problem is that you are manually checking alarms in another sequence, every 4.9 seconds.  Well, unless they happen to overlap, Reset_Alarms won't be 1 when the checking of alarms occurs.  The simple solution is to simply change your reset alarms function to:

 

Reset_Alarms = 1

alarm.checkAlarms()

Reset_Alarms = 0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this