Sign in to follow this  
XDK

Unknown Error In Draw

Recommended Posts

We have a program that crashes from time to time. 

post-11130-0-91470900-1428683371_thumb.j

 

The error message says "Unknown Error, save your document under a different name before proceeding: in draw". This happens randomly in a frequency of about once every few days.

 

The error is probably related to some of the objects under in the panel "MFC 1", "MFC 2"...  or the sequences related to them. If we remove these objects and sequences, the program can work for weeks without any problem. 

The objects and sequences under "MFC X" panels basically send a string with a RS232 serial port, parse the string that is returned, and then show the results on the panel. 

 

The ctl file is attached. New GMP V1.1.ctl

Would you please provide some idea on improving the stability of the program? Many thanks!

 

 

Share this post


Link to post
Share on other sites

What release of DAQFactory are you using?  5.87 it looks like maybe, though make sure you are on 5.87c, the latest.

 

Does it happen on its own, or when you are interacting with the system?

 

Try just stopping one sequence and see if you can isolate it.  Or switch to a blank page when you aren't looking at the system and see if it crashes while sitting on a blank page.

Share this post


Link to post
Share on other sites

Hi AzeoTech,

 

Thanks for the suggestion. We are trying to switch to a blank page when we are not looking at it and see what happens.

 

Currently we are using the 5.87c version with a 64-bit Windows 7 Professional SP1. Same problem was encountered on a computer running Windows Vista.

 

The error happens on its own. We typically let the sequences to run for a day or two, with occasional checking a few times a day.

 

It is very difficult for us to isolate the problem, because it happens randomly and not very frequently (probably once a week). 

Share this post


Link to post
Share on other sites

Hi Azeotech, 

Was there an answer to this problem? I'm getting just the same problem with a very simple version of the above?

Many thanks

Oli

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this