Recommended Posts

HI,

With win paint I am modifying a conveyor image from the Symbol Library (i.e. to simulate an inclined conveyor). Then I save the file. After that I import the above file in the Symbol Library and I paste the image on my HMI. By evaluating an expression, I change the color of the inclined conveyor (from black to green). I am facing the following problem: when the expression is true, the inclined conveyor becomes green but the background of the image becomes white covering in that way other images nearby. The problem does not exist when i am using images (inclined conveyors) from DAQFactory Symbol Library.

How can I modify images from the Symbol Library and use them on my HMI?

Thanks

Sdk

Share this post


Link to post
Share on other sites

That's because the symbols in the symbol library are not bitmap images, but vector graphics.  DAQFactory doesn't support transparent in bitmaps.  You have two choices:

 

1) use the symbol directly.  If all you want to do is incline it, why not just set the rotation parameter in the symbol component?  It will rotate it for you.

2) export the symbol as a WMF, then edit it with a WMF editor instead of Paint.  Illustrator sometimes works as a WMF editor, though I'm not sure about support in the latest releases.  There are other WMF editors on the web for a lot cheaper or free.  WMF is a vector file format.

Share this post


Link to post
Share on other sites

Is there a way to import vector graphics directly, or do you have to go via the symbol factory?

Share this post


Link to post
Share on other sites

You can, technically, paste a WMF graphic directly into DAQFactory.  The problem is that many applications, such as Illustrator, will put both the vector and a bitmap representation in the clipboard, and DAQFactory will prioritize the bitmap.  As such, you'll need to find a WMF editor to run your vector graphic through, opening it in that program, then copying it to the clipboard and pasting into DAQFactory.  We will be enhancing vector support with SVG in a future release.

Share this post


Link to post
Share on other sites

+1 for SVG, that would be great.

I'm not having any luck getting WMF directly into the symbol component, either from the clipboard, or using the load image button. Is it supported?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now