glaw54

Page locks up on particular device

Recommended Posts

Hi Guru

I have sent you the ctl file as a separate email. Two strange problems have developed. After a restart the last page called "web" will freeze the PC when selected, if the machine is left running for 24 Hrs it will sometimes come right  but not always. If the PC is put into safe mode and the page is selected before changing back to normal operation this  gives same result works 50% of the time. This only happens on one machine which used to operate normally.  Works fine on a  different PC but no differences between the two machines apart from brand.

Other problem is on page called feeders, you will see I have added a channel called  Feeder1_ca_voltage which does not display because of the colour selected, if I remove this channel  then the traces appear and disappear at around 20 second intervals. I have tried changing all other parameters in the graph but the extra unwanted channel seems to be the only cure.

Thanks in advance.

 

Share this post


Link to post
Share on other sites

First, what release of DAQFactory are you using?

2nd: the issue is probably related to the capture() functions.  What I would probably do is simply duplicate the page, and make it so capture() works on the duplicate and that you never actually view the duplicate.  That way, capture() is working on one copy, and local viewing is using the other and there is no conflict.

As to the feeders page, my guess is that the time width on the bottom axis is throwing it, that your feed1_ca_voltage has good time, but the others are skewed somehow, probably due to feeder2_importKW.  Try changing the bottom axis, unchecking Time Width, and setting the scale from to "systime()-48600" and scale to to "systime()"  If that fixes it, then that is the problem and you can either leave it, or figure out what is skewing the time.

 

 

 

Share this post


Link to post
Share on other sites

Thanks for the speedy response as always.

Duplicate page seems to be working fine. We are working on the graphs as suggested.

We are running 17.1 Build 2309

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now