ModbusTCP error. Two software devices


Systech
 Share

Recommended Posts

You will have to excuse me for speaking in layman terms.

I have inherited a SCADA system that was installed pre 2008. The system consists of 15+ moxa units spread across multiple locations. We have two Pc’s running the DaqFactory software. Recently we have enabled some new alarm inputs and updated the graphics.

Now we have a problem with the SCADA system notifying us of alarms.

When the new alarm inputs were tested on completion of the update, both software’s (device 1 and device 2) alerted of the alarms and the pop up notifications that were set up worked every time.

However, after a month of working correctly the alarms have begun failing to activate on both devices every time device. Sometimes the alarm will alert on device 1, Sometimes the alarms will alert on device 2 And sometimes the alarms will alert on both.

The errors being displayed in the Command alert are PmodusTCP 0010 timeout and C1038 timing lag acquisition stalled. These errors are different on each device and clear when the software is closed then reopened.

I have tried changing the offset timings on the new alarm inputs but this has not been successful in rectifying the issue.

Can anyone assist with this issue? I have added a few photos.

Feel free to request any further information and I will endeavour to provide it.

 

Thanks in advance.

comalert.png

channel2.png

20210325_095734.jpg

bw genny timeout.png

20210325_095743.jpg

Link to comment
Share on other sites

It looks like whatever you have happening is occurring every 5 seconds.  Since your Timing is set to 1, I can only assume that you have one of your ports set with a timeout value of 5.

The bottom line, though, is that you are getting Timeouts, meaning the device is not responding to queries.  The Timing Lag / Port Locked errors are ancillary and caused by the repetitive Timeout errors.  It is hard to tell exactly what is happening or which device is causing the issue, though it appears to be one with Offset = 0.68 and 0.73, so look there first.  There are a lot of things that could go wrong with the comms, but if it was working at one point, and now not working and the device is powered up, I would first look to see that you don't have an IP address conflict on your LAN.  I would also double check that no one changed the IP address of the device.  Next I would set the Timing of all your channels to 0 and try just reading one channel from each device.  Use the command/alert window and just type:

read(myChannel)

where mychannel is the name of some channel.  Have the comm monitor open for the desired device to see if you are getting a response.  Once you find one that isn't responding, figure out why.  Once you have everything communicating while reading one channel, you can reenable the TIming back to 1.

Link to comment
Share on other sites

  • 2 weeks later...

Thank You for your response. The alerting on each software is unpredictable. It may work one minute then not work the next minute. The IP address of each PC is set to DHCP so its unlikely there is a conflict. When changing the timings to 0 I have found that the errors stop happening on the software I am working on. The command alert screen is clear. The errors then begin on the other PC. I haven't been able to resolve the problem yet. I have disconnected the second PC. When the alarms are being tested now they are being received regularly on the PC that is still connected. No alerts are being missed currently but ideally I would like to reconnect the second PC and make them both work.

Link to comment
Share on other sites

Check the specs on the Moxa units to find out how many connections they support.  Or just turn off one computer, reboot the Moxa units and see if it works well with just one PC active.  If so, then you will likely need to setup DAQFactory in more of a master/slave setup where only one copy of DAQFactory communicates with the hardware.

Link to comment
Share on other sites

Depends on what the slave is doing.  If you are doing everything through channels, you can enable broadcasting on the master, then create a remote Connection on the slave, setting the Default Connection to this new Connection.  That should make it pretty easy to do.  Note that you would need Pro to utilize inter-DAQFactory networking.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share