Recommended Posts


I have a U3-HV. After working on redoing my sensors, the streaming will not work. I haven’t changed anything in my sequence. When calling startStream, it comes on for about 3 seconds and stops on its own. There is no stop stream in the sequence, so it should keep running. 
   I tried the example in guide with a 2d graph and buttons and nothing. 
   If I change timing to anything but 0, I get data, but not when I try to stream. I don’t know if it’s a DAQFactory problem or a Labjack problem. I can see values change in LJControl Panel so it seems to be in DAQ. 
  I will say that I had an accidental short from power to ground through my load cell shield wire to the frame of my shock dyno. It didn’t blow any fuses and the sensor was not hooked up, but don’t know if it sent a charge into Labjack through the ground connection. 
   As I said, it works with any timing but 0 for stream. 
  Is it possible that it corrupted the programming of either DAQ or Labjack?

 I reloaded Labjack firmware but still doesn’t work  


Link to comment
Share on other sites

Even without seeing my .cal document, I can’t even get it to stream by following the example in the manual. It’s definitely in the software. After talking with Labjack, I can stream in LJStreamUD. I’m going to try reloading the software and see. 

Link to comment
Share on other sites


1) avoid using ID 0.  It means "first found" and can have unpredictable results if you have more than one LabJack installed.  We use it in our sample because we don't know what ID you have

2) did you try the BasicStream.ctl sample in the LJGuideSamples folder of your DAQFactory installation?

3) Do you get any errors from the include() line?  It would be in the command/alert window.  The default (and what is displayed in the help) of c:\program files\ is for 32 bit operating systems.  If you have a 64 bit operating system, which is much more common now, you likely need to change it to: c:\program files (x86)\

4) I would add the ePut(0, LJ_ioPIN_CONFIGURATION_RESET, 0, 0, 0) command in there at startup to ensure the device is at default configuration

5) I would comment out th extra channels (lines 15-17).  Better yet, I'd first see if you can get just one channel to stream and get rid of most of the stuff in your startup sequence that has nothing to do with streaming.  When debugging, always make the system as simple as possible, then add complexity once you get things working.

6) I would also add the ErrorHandler() function as done in the BasicStream sample so you can be sure the device isn't reporting any errors.  Also display the scanrate variable on your page.  

Use script commenting to temporarily remove code.  Just put // at the left side of any line you want to comment out.  Then it is easy to add back in.


Link to comment
Share on other sites

I don’t understand why it just stopped working. I didn’t change anything in my scripts. It was working fine before, then it wasn’t. 
That script is just as it says in the Labjack with DAQFACTORY manual. 

Link to comment
Share on other sites

Right, but as I mentioned, that sample is for 32 bit operating systems.  For some reason Windows decided when they released 64 bit OSs to split Program Files into two: c:\program files for 64 bit apps, and c:\program files (x86) for 32 bit apps.  The LabJack software is 32 bit, so on 64 bit systems it ends up in a different folder than on 32 bit systems.  The sample is for 32 bit systems, so if you are on a 64 bit system, which is much more likely nowadays, it likely got installed in c:\program files (x86) and thus your include() statement in the DAQFactory script is incorrect.  I would expect you would see an error about this in the command/alert window as well.

Link to comment
Share on other sites

I can’t get anything to stream. Even with timing set to 0.1, the outputs look erratic. I’m thinking I probably did damage to the Labjack when it shorted. I’m going to order a new one and start over. 

Link to comment
Share on other sites

That is possible.  I have seen people destroying LabJacks (and other manufacturer's devices) with shorts.  It often kills just part of the device so it still communicates but things just don't work as expected.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.