Sign in to follow this  
phillyjoe

Thermocouple Inputs with EI-1040

Recommended Posts

Am trying to get TCs to read out in degrees C on the page view. The EI-1040 amp outputs are set to a gain of 1. I have only been able to get raw voltage values at this point. TypeK has been spec'd for the conversion in channel view.

Share this post


Link to post
Share on other sites

A few things:

1) You need the EI-1040 at a gain of 100 or 1000 to read thermocouples. Thermocouples output between -5 and 2 mV (give or take). The LabJack inputs at maximum gain (+/-1 V) have a step size of 0.4 mV. This gives you about 15 steps across the entire range of the thermocouple, which is typically 1000 degrees or so. A gain of 1 on the EI-1040 doesn't really do anything but solve impedence problems. A gain of 10 will give you 150 steps across 1000 degrees, which is still pretty bad. Thus 100 or preferably 1000 gain will work best.

2) To properly use thermocouples you have to take into account cold junction compensation. This is to take care of the voltage that is generated between the thermocouple wire and the screw terminal. To do CJC you typically measure the temperature of the screw terminal itself with a thermistor or other temperature device (but not a thermocouple), or, depending on the accuracy you need and the stability of the temperature of the screw terminal, you can often just use a constant like 25C (or whatever your room temperature is).

3) The functions in DAQFactory for converting a voltage into a temperature, such as the TypeK function, require a CJC number as the second parameter, otherwise the function will fail. If a Conversion fails, DAQFactory will simply return the unconverted value, thus the reason you still see raw voltage values. So, to solve your problem, make your conversion read something like: "TypeK(Value,25)" and apply the conversion to your input channel. This example uses 25C as your CJC.

Do these things and you'll be golden. Depending on your temperature range, you may want to consider the EI-1022 temperature probe. This sensor gives a 0-5V measurement which is much easier to read with the LabJack (no 1040 required) and has a very simple Volts to C conversion.

Share this post


Link to post
Share on other sites
Guest Bob Goober

The datasheet on the EI-1040 states that it uses a PGA204 instrumentation amplifier, so you could probably save the $90 on a EI-1040 and sample a bunch of PGA204s for free from Texas Instruments. You'll just have to configure it yourself on proto-board.

Share this post


Link to post
Share on other sites

Don't forget a bias return resistor when using the EI-1040 with thermocouples. This is mentioned in the EI-1040 datasheet, and in the following app note:

http://www.designcircuit.com/eic/tc4.htm

The EI-1040 actually has 2 of the PGA204 and a power converter to generate the +/-15 volts needed for the EI-1040. If you plan to go on your own and just use an instrumentation amplifier IC, I would recommend a different part. Perhaps a single-supply in-amp. Another option is the AD595 mentioned in various other thermocouple forum posts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this