Why I Always Have The Same Error "could Not Claim Labjack"

Recommended Posts


I'm using a LJ U12 and DAQ Factory for monitoring of research.
The program runs but I always have the same error during all day.

First, it work very well, but suddenly this error appears  Then I receive the following codes
D0004_1009 Labjack U!": Gerneral error: could not claim Labjack

I get this message while the program runs normal.

could you please explain me what this messages mean.
do you have any ideas what's the problem in my case.

thanks for your help 


Link to comment
Share on other sites

Make sure you are only running 1 program (1 copy of DAQFactory) that might be talking to the U12.  That error usually means some other program has claimed the U12.


Is the error intermittent, or once you get the error can you no longer talk to the U12?


Run LJtest (with no other programs running) and make sure it reports that you are using U12 version 1.22.  Note that if you want LJtest to pass all tests you need to have nothing connected to the U12 except for the USB cable.


Are you using stream or burst mode, or just channels in the DF Channels list with normal command/response timing?


If you make a simple new DF CTL from scratch that simply acquires AI0 at a 1.00 second interval, does it have the same issue?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.