remote connection failure

Recommended Posts

Hi I have upgraded to version 5.85 and all seems to be working on the server system as far as aquiring and logging data but I have been unable to connect the remote system to the server.

I get the following message " unable to decrypt packet "

I tried the connection in reverse and I got the message

"unable to encrypt packet "

in both instances the connection page said connected but no channels were visible and no packets were seen to be exchanging?

both machines ungraded with no errors, the disable box is unchecked in the doc settings - pretty much ran out of ideas ???????

Link to comment
Share on other sites

Did you specify a password on either side?

What country are you in?

The connection page will say connected if the socket can be created.

Are you sure about the error message? I need the exact error message. You will never get a simple "unable to encrypt packet" error, but rather "Failed to send packet, encryption failed". You can get a "Failed to decrypt packet" error.

Do you get a message saying "Encrypting network data" in the command alert when the first connection is established? You'd get it on both sides.

Link to comment
Share on other sites


I am in the UK

on the client you get the encrypting network data message in the command alert

on the server you get failed to decrypt packet if. If i try to get daqfactory to connect to itsself on the server I get both messages. If i try to get the server to connect to the client I get the failed to send packet encryption failed message.

I have set the same password and tried with no password set - same issue

I have also tried to reinstall daqfactory same issue ....

tried another experiment opened a new document on the server and tried a remote connection - same issues .......

any ideas ?

Link to comment
Share on other sites

To ensure we follow export regulations, DAQFactory uses the encryption tools provided by the Windows operating system. It is most likely that the server does not have the full encryption toolset installed. That leaves you a couple choices:

1) install the Windows Cryptography API on the server. You'll have to check the Microsoft website to find the Cryptography library appropriate for your country. I believe the file is Crypt32.dll. You might be able to simply copy the file from the client. I would backup the existing file first.

2) disable encryption by deleting or renaming the socketE.dll file from the DAQFactory directory. Not recommended unless your network is compelely isolated, or your system is not mission critical. Make sure that the reboot/shutdown is disabled.

Link to comment
Share on other sites

My guess is that your server computer had some old copy of crypt32.dll that doesn't support the encryption algorithm we use. Again, because of export regulations, we have to rely on windows and can't simply provide our own dll or even a copy of a working crypt32.dll.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.