Development Environment


trisol
 Share

Recommended Posts

Hello,  I have somehow managed in one of my .ctl files to size the text in all the development editors to such a small size it is almost impossible to read/use them correclty.  Ran install repair and have searched through the options and also knowledgebase topics on how to reset without success.  Anyone able to assist?  Greatly appreciated.

SmallTextEditor.JPG

Link to comment
Share on other sites

I'm guessing that you have a 4K monitor.  DAQFactory has been around for a long time (20+ years) and back then monitors were all pretty low res.  Only recently have 4K monitors on little 17 inch screens become the norm.  Windows added support for this, but it is a new thing and we haven't implemented it yet in the release.  It will, however, be resolved in the next, 20.1, release I expect.  Until then, the fix is super easy:

1) open Explorer and find DAQFactory.exe in your installation folder
2) right click on it and select Properties
3) go to the Compatibility tab, and click on Change high DPI settings
4) check the box towards the bottom that says "Override high DPI scaling behavior.
5) in the drop down just below this select "System (Enhanced)"
6) close out the properties windows and start DAQFactory.
 
Link to comment
Share on other sites

Hi Guru,

Thank you fro your prompt response.

No running on laptop PC with default Win 10 settings and also extended external monitor; both 1024 x 768 .  Tried modifying the DPI scaling and tried all options,  also tried running in Win 7 compatibility mode.

When setting as suggested I get a rogue table appear over my graphics page (see attached) and selecting a new project the channel editor column headers are still small.

DPI Setting Change.png

Link to comment
Share on other sites

OK if you aren't a 4k monitor, then your DPI is just fine and you should revert those settings.

It sounds like you may have just played with the preferences and inadvertently set them small.  The best thing is probably to just erase the settings in the registry so DAQFactory goes back to defaults.  An uninstall won't do this.  You'll need to quit DAQFactory, then fire up the Windows registry editor, and then delete the following folders and their contents:

\HKEY_CURRENT_USER\SOFTWARE\DAQFactory\DAQFactory\BCGWorkspace2

\HKEY_CURRENT_USER\SOFTWARE\DAQFactory\DAQFactory\RuntimeBCG2

Then go to:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\DAQFactory\Control

and delete all the keys in that folder, while keeping the folder (to save any registry variables you might have).  You can also delete these two folders if you want:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\DAQFactory\Control\ChannelTablePrefs

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\DAQFactory\Control\Preferences

 

 

 

Link to comment
Share on other sites

Deleted entries as detailed above, no good.

Uninstalled DAQF, searched all registry entries for Azeotech and DAQF and deleted except for multiple entries in:

UserSettings\S-1-5-21-..........\Device\HardiskVolume.....  (warning about disk issues).

Deleted any folders/files on local PC related to AzeroTehc or DAQF.

Re-started PC to flush any memory resident data.

Reinstalled DAQFv19.1, now have the defaut 25-day trial grace period development licence (instead of needing to use my developent USB dongle) and still table editors text font is tiny.

You mentioned that I may have inadvertently set the font size to small in preferences; this can't be the case now?  The only preferences referencing font size I can find are table font size and sequence editor font size and these are the default 8-points and 10-points resectively.

Link to comment
Share on other sites

Thanks to awesomely quick response from support issue is now resolved.  When adjusting font size also change font type as this seems to trigger the text size refresh - simple when you know how!

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share