Russian language


Recommended Posts

You need to select a font that actually has russian characters. It sounds like Arial (the default) does not. Do you see Russian in the properties window of a Static Text component and then it does not appear on the page? That would confirm this. I would then just try different fonts until one displays correctly.

Link to comment
Share on other sites

The current versions of DAQFactory use code pages for extended languages. (6.0 will be unicode). In order for it to work, you have to have window Regional and Language options set correctly. Go to control panel and Regional and Language options (I'm assuming XP, I don't know where it is in Vista). Then go to the advanced tab, and make sure the code page for Russian is checked. Probably 866 (OEM Russian). You will then also need to select Russian from the "Language for non-Unicode programs" section.

Link to comment
Share on other sites

  • 7 years later...



I try this way for Vietnamese but it doesn't help. I use window 7. 

I also tried to chang language of Window to Vietnamese, "Change system locale ..." in "Region and language" to Vietnamese.

Nothing works.

Please advice me the solution.



Link to comment
Share on other sites

You may need to tell DAQFactory the code page you want to use.  To do so, open the registry and go to either:




or, if you are using 64 bit Windows:




Create a new DWORD entry called:




and set it to the desired code page.  Check the internet for the correct one.  My first looks seems to indicate 1258.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.