upgrade to 5.84 crashes DAQFactory Starter


Recommended Posts


I had a licenced version of DAQFactory Starter 5.83 wich I tried to upgrade to 5.84.

I had a warning during automatic installation, like "unable to register in (...)\system32(...) dll (...)" and I clicked OK (the only choice I had).

Then I got a message talking about "roling back" (?)

Now, when I try to launch DAQFactory, I get a message "licence error occured, contact technical support".

I like DAQFactory, but what happened to me is a pure (paying) user nightmare : The website said it was easy to upgrade and that the licence will be kept, I trusted that and tried to upgrade. Now DAQFactory is broken and measurments stucked.

I feel a little bit of disapointed.

What can I do to have a working version of DAQFactory ?

Link to comment
Share on other sites

My guess is that you didn't install as an administrator. As such, even the rollback doesn't work properly, so now you have a partial installation. The easiest thing to do is probably to delete the DAQFactory directory (or rename it), then reinstall, making sure you are an administrator so that the installer can register the proper controls. The license is in the registry so should pick up, provided the install is complete.

And yes, it is simple to upgrade. You don't have to relicense, you don't have to do anything but re-run the installer properly.

Link to comment
Share on other sites

I deleted the DAQFActory directory and tried to re-install, loged as an administrator and with the anri-virus desactivated.

I got an error "Cannot register C\WINDOWS\System32\OPCENUM.exe" and the installation aborted.

I tried to install an earlier version (5.79), same problem.

I do have and OPCENUM.EXE (v 1.10, 132 ko) I my system32 directory and a lot of keys pointing to OPCENUM.EXE in the registry base.

A short googling showed that OPCENUM.EXE is related to some server system.

So I tried to re-install, unchecking "OPC device" when asked for device selection.

The install ran fine and after unlocking trough internet and entering the key I had, DAQFactory works again.

When creating a new channel, I still have an OPC choice in the device type column.

So it seems that :

- re-installing OPC over an exixting OPC installation stucks the DAQFactory install,

- "rollback " after installation don't allway works as expected.

Link to comment
Share on other sites

OPCEnum is a shared file, kind of like MFC and .NET files, and is actually provided by the OPC foundation. Its possible something else is using the file in the system, or you have other OPC files in your system that the installer doesn't expect and that keeps the OPCEnum from registering (because of differing version numbers). The installer won't remove this file because it doesn't know if another application installed it. Anyhow, it sounds like a weird fluke. Unless you need OPC, I would just not worry about it. OPCEnum is only needed if you use the OPC device driver.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.