Ethernet connectivity


Recommended Posts

Hi Guru,

I have an MCU with an ethernet TCP/IP server application that sending data package. Attach is the raw data that I capture using device monitor studio software tool.

I set up DF ethernet TCP/IP client (IP:, Port: 5001)

I don't see anything on the DF COM monitor. when I tried to send out something from DF, it keep saying the port is busy.

Do you have any suggestion?    


Link to comment
Share on other sites

When you try and send something out a TCP port in DAQFactory and it gives you "Port is busy" it most likely means that the socket could not be established and the port is busy trying to establish it.  In general that usually means you got the IP address or Port # wrong.  5001 is an unusual port # for Modbus TCP.  502 is the standard.  Also, its possible that your device can only handle one connection and so while your other tool is running, DAQFactory can't connect.


Note that this does not apply to serial ports.  For serial ports, if you get Port is busy when you try and send, it usually means its locked due to other comms.

Link to comment
Share on other sites

That would do it.  It's easy to forget that connecting over Ethernet requires more than just the IP address.  The IP address just gets you to the proper office building.  You also need to know what the port number is to get to the right office in the building and there are 65535 offices in the building and 99.99% are empty.

If your MCU is going to act as a standard ModbusTCP slave, put it on port 502, as that is the standard port and anyone doing Modbus TCP is going to try 502 first without looking at any documentation you provide.  Also, you should avoid port's below 256 as they are kind of "reserved".

Link to comment
Share on other sites

  • 3 years later...

Hi, I am evaluating SCADA's for a small 21 PLC project for a semiconductor manufacturer. I am having the same issues using a Mitsubishi FX3U and an ENET module set to an IP and port 5000. I started with port 5000 for Fernhill which I evaluated and it is working. Now I am on to DAQFactory. I tried a few ports and cannot connect due to port is busy. I am just trying to determine learning curve by just a quick setup and evaluating a digital I/O and an internal word.

The server is a new WIN10 PRO build with WIFI turned off. IPv4 set to and module set to and it pings fine.

Link to comment
Share on other sites

Go to the monitor and try just typing one character and then Send.  If it comes back "port is busy" then it almost certainly means that DAQFactory was unable to open a socket connection to that IP/Port combination.  This sometimes happens when one gets the IP or more likely, the port incorrect.  It also happens when the device has a limit on the number of active connections, which most devices do, and you've reached that because you have some other software connecting to the PLC.

Link to comment
Share on other sites

Different combination also did not work. I am pinging fine. Unsure if I need to install additional DAQFactory Software. I even tried to reserve the port, bad hail mary. Is there any special mapping that is required> This is with firewall disabled and enabled. The firewall has daqfactory allowances. My last effort would be using a router and try some port method that way.

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP        INTEL-NUC:49674        ESTABLISHED
  TCP        INTEL-NUC:49153        ESTABLISHED

Link to comment
Share on other sites

This is an outgoing connection to your device, so no firewall issues.  Allowing DAQFactory for the firewall would be for incoming, like using DAQFactory as a web server, or for Connections to 2nd instances of DAQFactory.

I would do this:

1) reboot the computer
2) start DAQFactory
3) go to Quick - Device Configuration -> New Serial Ethernet device.
4) add a new Ethernet Client, use the IP / Port you think will work.
5) select Monitor to popup the monitor window.  Try just typing something and hitting send. If it gives you Port Locked then DAQFactory is unable to open a socket to the device and the issue is outside DAQFactory, or you have the wrong IP/Port.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.