DAQ not filling second screen

Recommended Posts


Have a laptop with a higher resolution external monitor. When I run DAQ on the external monitor it refuses to fill the screen when maximised. This is in development mode. All other Windows application adjust ok between laptop and external monitor ok, but DAQ remains fixed at a maximum size equal to the laptop screen. This used to work ok but something has changed. All suggestions welcomed.

Link to comment
Share on other sites

DAQFactory uses a rather old technique called double buffering to create flicker free animations.  To do this, it has to create a copy of the screen memory.  It then draws on that copy, then copies that entire block over to the video memory.  To do this, it has to allocate memory for that background buffer.  By default, it will use the screen resolution of the primary monitor of the system to create the memory without over doing it.  However, this creates problems, such as you are seeing, when the primary monitor has a lower resolution than a secondary monitor.  Then, the buffer is too small for that second monitor and you will see the pages clipped at whatever the resolution of the primary monitor is.  (it is actually square, as a 1280x1024 monitor would create a 1280x1280 buffer).

Fortunately there is a way to override this.  If you create a DWORD registry variable named "ScreenRes" at this path:


and set this to the desired size, which should be the largest resolution number, it will use this value instead of the primary monitor resolution to create this buffer.  So, if your primary screen is 1280x1024, and your secondary monitor is 1920x1280, then you would want to set the ScreenRes registry variable to 1920 (decimal).

Note that on 32 bit machines you would not have WOW6432NODE and the path would be:


Link to comment
Share on other sites

Yes, you did it correctly, though I am not sure the number is big enough.  Try 5000 decimal just to see if it helps.  But also it appears your issue is that the entire DAQFactory window won't expand, not that the screen doesn't draw.  I have only rarely seen this.  I have a 49" wide monitor, and previous had a 4k 43" and didn't have issues.  A couple other things to try: 

1) make that monitor the primary monitor

2) go into the properties for DAQFactory.exe and try a couple compatibility modes.  Specifically, try going to "Change Hight DPI settings" and set the High DPI override to System Enhanced.  But it might be something else there. 

Link to comment
Share on other sites

I tried 5000 but no change. Same as you this used to work fine but something has changed, I don't remember doing anything that I think could affect it.

When the external is the primary/only monitor it works fine. Leaving DAQ open on the external screen, I change it back to extend it moves DAQ to the laptop screen. When I then drag it to the extended screen it remains laptop screen size and won't expand further.

I tried compatibility to Windows 8 - no change. I tried changing 'High DPI settings' to System (Enhanced) - no change. I'm running Windows 10 BTW.

Life's weird sometimes!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.